FormaCars

Visit our community sponsor

Results 1 to 13 of 13

Thread: Parking brake cable

  1. #1

    Parking brake cable

    Are there varying lengths of cables for different ebrake handles? I have a bunch of slack between the lever to the T where the cables are mounted to the rear tunnel cover. There is enough slack that I canít get any tension on the brakes. Shoe thickness seems fine and the brake lever is mounted several inches in front of the tunnel cover

  2. #2
    The wagon and sedan cables are different but both should work.

    I think from your description you may need to run the doubled-up 10mm nut on the handle down all the way the down. Mine is all the way down and engagement is just acceptable.

  3. #3
    Yeah I’ve already adjusted the 10mm to use every bit of thread available and still have too much slack

  4. #4
    Senior Member STiPWRD's Avatar
    Join Date
    Jan 2014
    Location
    Leesburg, VA
    Posts
    1,292
    It sound like you need to increase the distance from the cable mount to the lever. That should remove the slack.

  5. #5
    Yeah Iíve move the handle as far forward as possibly, Iím butting up against Wayneís box
    Shifter and donít want to move that more fwd.

  6. #6
    Senior Member STiPWRD's Avatar
    Join Date
    Jan 2014
    Location
    Leesburg, VA
    Posts
    1,292
    You'll probably have to move the cable mount backwards. I didn't want to use the rear tunnel cover so I made my own mount.
    IMAG1297.jpg
    You may have to do the same.

  7. #7
    Thanks, Iíll have to keep loooking for some options... The cable on your lever seems much shorter than mine. I have the adjuster threaded to the max and it still looks longer than yours.
    Last edited by SnyderJD; 02-13-2018 at 11:06 AM.

  8. #8
    Senior Member STiPWRD's Avatar
    Join Date
    Jan 2014
    Location
    Leesburg, VA
    Posts
    1,292
    That's interesting. There could be some sort of different between the wagon and sedan like Phil said. My cables are from an 02 wrx sedan. Do you have any pics of your parking brake setup?

  9. #9
    I had to convert from drums in the rear and remember there being two different lengths for cables sedan vs wagon. Looking back at Rockauto now it also appears there may be two different lengths of "front" cable (the part with the threaded adjuster) available. One lists overall length as 9.25" and the other 9.75". Could be just a typo.

    Also make sure your parking brake shoes are adjusted properly if you haven't. Just a few turns of the star adjuster can make a huge difference in my experience.

  10. #10
    Quote Originally Posted by phil1734 View Post
    I had to convert from drums in the rear and remember there being two different lengths for cables sedan vs wagon. Looking back at Rockauto now it also appears there may be two different lengths of "front" cable (the part with the threaded adjuster) available. One lists overall length as 9.25" and the other 9.75". Could be just a typo.

    Also make sure your parking brake shoes are adjusted properly if you haven't. Just a few turns of the star adjuster can make a huge difference in my experience.
    Iíve already adjusted the star on the drum so this binds and then backed off one click. The different length front cable I think is the issue. Iím looking into that now thanks

  11. #11
    Not sure if you got the answer you needed, but yes - there are different lengths. 2002-2004 WRX/STI sedans use a different e-brake than 2005-2007 WRX/STI sedans. They don't interchange. You can see the difference between the center consoles between those year groups. I am unsure of the wagons and if they differ in length.

  12. #12
    @axelthrasher. Do you know which front cable is shorter?

  13. #13
    Quote Originally Posted by SnyderJD View Post
    @axelthrasher. Do you know which front cable is shorter?
    Don't quote me 100%, but I thought the 02-04 e-brake cables are shorter than the 05-07. I have a couple of sets in my garage somewhere... But at this point I'm not even sure which was which anymore. :-/

    This may help: https://forums.nasioc.com/forums/sho....php?t=1931492

    From the above thread: "Originally Posted by americanyouth View Post
    FYI, the issues you ran into isn't exactly caused by the fact you swapped to an STi rear end. All 04 cables are actually longer than all 05-07 cables, because of the different style ebrake handles and center consoles."

    Sorry for the conflicting information. :-(
    Last edited by axelthrasher; 02-16-2018 at 09:36 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Lodestone Billetworks

Visit our community sponsor