Miller Customs

Visit our community sponsor

Thanks Thanks:  0
Likes Likes:  0
Page 2 of 2 FirstFirst 12
Results 41 to 71 of 71

Thread: Holley HP EFI help needed - BACKFIRE: SUCCESS!

  1. #41
    Administrator David Hodgkins's Avatar
    Join Date
    Feb 2011
    Location
    Corona del Mar, CA
    Posts
    4,994
    Post Thanks / Like
    Blog Entries
    7
    Quote Originally Posted by bobl View Post
    Timing shows to be around 25 in the timing table and on the dash display. I can't tell from the data log snapshot. If you want, email me the datalogs you have and I'll study them. I don't normally run near that much timing at idle but if it ran good before then I would be looking elsewhere for a problem. [email protected]
    That's what I'm thinking. Should be around 10 - 11 degrees, right? I didn't get to the shop last night, so no timing light done.

    I'll send you the log, thanks.


    FFR 5369 Pin Drive, IRS, Trigos, Torsen, Wilwoods, FMS BOSS 302 "B" cam , Mass-flo. CA SB100 (SPCN) Registered
    Delivered 4/23/06. "Finished" 4/2012 (still not done!)


  2. #42
    bobl's Avatar
    Join Date
    Aug 2014
    Posts
    194
    Post Thanks / Like
    Somewhere in that range. Just have to figure out what works best. You will need to have a gradual ramp up in timing as map and rpm increase or it will be jerky to drive.

    Quote Originally Posted by David Hodgkins View Post
    That's what I'm thinking. Should be around 10 - 11 degrees, right? I didn't get to the shop last night, so no timing light done.

    I'll send you the log, thanks.

    Mk IV Roadster, 347/516 HP, 8 stack injection, Astro Performance T5, 3-Link 3.55 gears, Purchased 08/2015, Graduated 02/2017

  3. #43
    Itchief's Avatar
    Join Date
    Aug 2017
    Location
    Southern WV
    Posts
    285
    Post Thanks / Like
    David

    Did you resolve your backfire issues
    #8475 Complete Kit Delivered Nov 2014, started Nov 2015, Street Legal Apr 2016, Paint and Interior Completed Aug 2017, 390 BBF, March accessory kit, MSD Atomic EFI and Ready to run, TKO 500 with MidShift kit, hooker headers, 3 link, track lock with 3.55, sway bars, power steering, wipers, heater

  4. #44
    Administrator David Hodgkins's Avatar
    Join Date
    Feb 2011
    Location
    Corona del Mar, CA
    Posts
    4,994
    Post Thanks / Like
    Blog Entries
    7
    Quote Originally Posted by Itchief View Post
    David

    Did you resolve your backfire issues
    No I haven't. I have some log files I need to send to someone to interpret. Checking with Holley...

    FFR 5369 Pin Drive, IRS, Trigos, Torsen, Wilwoods, FMS BOSS 302 "B" cam , Mass-flo. CA SB100 (SPCN) Registered
    Delivered 4/23/06. "Finished" 4/2012 (still not done!)


  5. #45
    Administrator David Hodgkins's Avatar
    Join Date
    Feb 2011
    Location
    Corona del Mar, CA
    Posts
    4,994
    Post Thanks / Like
    Blog Entries
    7
    Zipped log files attached. Backfire data should be included since it happened while logging...
    Attached Files Attached Files

    FFR 5369 Pin Drive, IRS, Trigos, Torsen, Wilwoods, FMS BOSS 302 "B" cam , Mass-flo. CA SB100 (SPCN) Registered
    Delivered 4/23/06. "Finished" 4/2012 (still not done!)


  6. #46
    Itchief's Avatar
    Join Date
    Aug 2017
    Location
    Southern WV
    Posts
    285
    Post Thanks / Like
    Did you have the backfire issue before you changed the spark plugs
    #8475 Complete Kit Delivered Nov 2014, started Nov 2015, Street Legal Apr 2016, Paint and Interior Completed Aug 2017, 390 BBF, March accessory kit, MSD Atomic EFI and Ready to run, TKO 500 with MidShift kit, hooker headers, 3 link, track lock with 3.55, sway bars, power steering, wipers, heater

  7. #47
    Administrator David Hodgkins's Avatar
    Join Date
    Feb 2011
    Location
    Corona del Mar, CA
    Posts
    4,994
    Post Thanks / Like
    Blog Entries
    7
    Quote Originally Posted by Itchief View Post
    Did you have the backfire issue before you changed the spark plugs
    Yes sir.

    FFR 5369 Pin Drive, IRS, Trigos, Torsen, Wilwoods, FMS BOSS 302 "B" cam , Mass-flo. CA SB100 (SPCN) Registered
    Delivered 4/23/06. "Finished" 4/2012 (still not done!)


  8. #48
    Itchief's Avatar
    Join Date
    Aug 2017
    Location
    Southern WV
    Posts
    285
    Post Thanks / Like
    Ok

    Just a thought if you have a dual plane intake and one of the injectors is not closing properly and is dumping too much fuel into the intake would that cause the backfire issue

    Do the new plugs on that side look wet after running the motor

    Good luck

    Rick
    #8475 Complete Kit Delivered Nov 2014, started Nov 2015, Street Legal Apr 2016, Paint and Interior Completed Aug 2017, 390 BBF, March accessory kit, MSD Atomic EFI and Ready to run, TKO 500 with MidShift kit, hooker headers, 3 link, track lock with 3.55, sway bars, power steering, wipers, heater

  9. #49
    Administrator David Hodgkins's Avatar
    Join Date
    Feb 2011
    Location
    Corona del Mar, CA
    Posts
    4,994
    Post Thanks / Like
    Blog Entries
    7
    Thanks for the thought Rick!

    I'll pull the driver's side plugs after running it for a bit and I'll take a look.


    FFR 5369 Pin Drive, IRS, Trigos, Torsen, Wilwoods, FMS BOSS 302 "B" cam , Mass-flo. CA SB100 (SPCN) Registered
    Delivered 4/23/06. "Finished" 4/2012 (still not done!)


  10. #50
    Itchief's Avatar
    Join Date
    Aug 2017
    Location
    Southern WV
    Posts
    285
    Post Thanks / Like
    The excess fuel may also explain the spark plug fouling
    #8475 Complete Kit Delivered Nov 2014, started Nov 2015, Street Legal Apr 2016, Paint and Interior Completed Aug 2017, 390 BBF, March accessory kit, MSD Atomic EFI and Ready to run, TKO 500 with MidShift kit, hooker headers, 3 link, track lock with 3.55, sway bars, power steering, wipers, heater

  11. #51
    Administrator G_Hodgkins's Avatar
    Join Date
    Feb 2011
    Posts
    63
    Post Thanks / Like
    Blog Entries
    3
    Glad to see you decided to fix this, it's only been like a year!

  12. #52
    Administrator David Hodgkins's Avatar
    Join Date
    Feb 2011
    Location
    Corona del Mar, CA
    Posts
    4,994
    Post Thanks / Like
    Blog Entries
    7
    Quote Originally Posted by G_Hodgkins View Post
    Glad to see you decided to fix this, it's only been like a year!
    Hey YOU! Back to work!

    consin fraggin friggle frumpllll conis flaglll grrrrrrrrrr.....

    FFR 5369 Pin Drive, IRS, Trigos, Torsen, Wilwoods, FMS BOSS 302 "B" cam , Mass-flo. CA SB100 (SPCN) Registered
    Delivered 4/23/06. "Finished" 4/2012 (still not done!)


  13. #53
    Senior Member Clover's Avatar
    Join Date
    Feb 2016
    Location
    Colorado
    Posts
    197
    Post Thanks / Like
    Quote Originally Posted by G_Hodgkins View Post
    Glad to see you decided to fix this, it's only been like a year!
    Ha Ha! You may have left the house but your sarcasm remains. Good sons always needle their fathers.

  14. #54
    Senior Member Clover's Avatar
    Join Date
    Feb 2016
    Location
    Colorado
    Posts
    197
    Post Thanks / Like
    Oops double post. Karma I guess.
    Last edited by Clover; 06-14-2018 at 11:53 AM.

  15. #55
    Administrator David Hodgkins's Avatar
    Join Date
    Feb 2011
    Location
    Corona del Mar, CA
    Posts
    4,994
    Post Thanks / Like
    Blog Entries
    7
    OK as embarrassing as this is, I'm bringing it back to the top.

    I've been communicating with Holley and sent them my Global files.

    I went and checked to see how the wires are run currently. Here's what I have:



    Does this look correct? To me it looks like the firing order is 1-8-4-2-5-3-6-7! It doesn't look right to me based on another graphic they sent:



    My firing order in the EFI program:



    Holley said this is a CHEVY firing order(1) and sent me a new config that looks like this:



    OK so I see that this has been changed, but Holley said keep the spark wires the same. Is that right?

    In any event I'm excited to make this change and see if it FINALLY fixes my issues!

    Last edited by David Hodgkins; 09-26-2018 at 06:44 PM.

    FFR 5369 Pin Drive, IRS, Trigos, Torsen, Wilwoods, FMS BOSS 302 "B" cam , Mass-flo. CA SB100 (SPCN) Registered
    Delivered 4/23/06. "Finished" 4/2012 (still not done!)


  16. #56
    Member Geoff H's Avatar
    Join Date
    Feb 2011
    Location
    Edmonton, Alberta
    Posts
    40
    Post Thanks / Like
    Hi David. I am new to your challenges so bear with me if I say something you have already tried.

    If you have the B Cam I believe you should be running the windsor firing order 1, 3, 7, 2, 6, 5, 4, 8 - which is what they recommended for you. I don't know your system, but I don't see how you can change the firing order without changing the order of the wires. The program may change the order of when the injectors pulse, but I would think you need to actually change the order of the wires to correct the firing order.

    Just my thoughts,

    Geoff

  17. #57
    Senior Member weendoggy's Avatar
    Join Date
    Feb 2011
    Location
    Aptos, CA
    Posts
    121
    Post Thanks / Like
    It doesn't matter where #1 is on the cap. It depends on HOW you installed the distributor for #1. Just by taking a look at the cap wiring (CCW), I can see the #1 wire looks to be on terminal from the hold down next to wire 8. However, because I can see what's done, it's a guess due to your picture. The engine wouldn't run very well on the 1,8,4... firing order anyway so it may be correct. However (again), if you're running the SEFI Ford system and using the TFI or Dual Sync distributor setup, to correctly get the injectors to fire correctly you MUST put the correct order in the software as Holley has done and what Geoff H said as well. It needs to know! Just because the wire has a number on it doesn't mean it's going to that plug, check them to make sure of the firing order: 1,3,7,2,6,5,4,8 for a Ford EFI 5.0.

    You should get back to basics and find out how the distributor is installed on #1 and go from there to insure the order is correct and wires routed correct. As I said, it wouldn't run well with the incorrect PHYSICAL wiring order.
    Last edited by weendoggy; 09-27-2018 at 09:25 AM.
    I'm just a victim of a thousand physic wars!
    www.weendoggy.com/cobra.htm

  18. #58
    Administrator David Hodgkins's Avatar
    Join Date
    Feb 2011
    Location
    Corona del Mar, CA
    Posts
    4,994
    Post Thanks / Like
    Blog Entries
    7
    I made a mistake mapping the wires.

    Using these two shots:





    ... it looks like I mis-identified the wired firing order but it is still incorrect. I get 1-3-5-2-6-7-4-8 tracing the wires and disregarding the wire labeling. What do you see?

    I started the car yesterday and it's still not right. I'll change them to 1-3-7-2-6-5-4-8 and try again.

    I'm such an idiot.
    Last edited by David Hodgkins; 09-27-2018 at 11:35 AM.

    FFR 5369 Pin Drive, IRS, Trigos, Torsen, Wilwoods, FMS BOSS 302 "B" cam , Mass-flo. CA SB100 (SPCN) Registered
    Delivered 4/23/06. "Finished" 4/2012 (still not done!)


  19. #59
    Member Geoff H's Avatar
    Join Date
    Feb 2011
    Location
    Edmonton, Alberta
    Posts
    40
    Post Thanks / Like
    Not all David. I could retire early with all the money I have spent trouble shooting only to find a very obvious and free solution right in front of me. That's why I have so many tape measures - one of the most elusive tools in the world I think.

    Looking forward to hearing if it makes a difference.

    Geoff

  20. #60
    Junior Member TBull's Avatar
    Join Date
    Dec 2011
    Location
    St. Louis
    Posts
    18
    Post Thanks / Like
    David, don't feel bad, it's happened to us all if you've been around cars very long. That's why the 1-3-7-2-6-5-4-8 in indelibly printed in my head, because of things like this. Real glad you found the issue. On a second note though, how do you like the Holley HP EFI system and the software. This is the setup I've been planning to use on my next car. It supposedly handles boost control, fan control and may other items along with good data logging and ease of use. How would you rate your experience with Holley and their support? I mean the darn mice caused a good portion of this I realize, but from your screen shots I'm very hopeful.

  21. #61
    Senior Member weendoggy's Avatar
    Join Date
    Feb 2011
    Location
    Aptos, CA
    Posts
    121
    Post Thanks / Like
    First thing you need to do is find TDC on #1. Provided your timing is good, no need to adjust anything, just make sure #1 is on or near TDC and check the wiring at the cap. Also make sure the rotor is pointing to that terminal. After that, make sure ALL the plug wires go to the correct plug in the firing order. It doesn't matter if the wire has a number and it's on another plug as long as the routing is correct.

    Did you do any IEA adjustments in the software? I also see you have a Knock sensor checked, do you have one installed and wired on that engine?
    I'm just a victim of a thousand physic wars!
    www.weendoggy.com/cobra.htm

  22. #62
    Junior Member
    Join Date
    Oct 2017
    Posts
    19
    Post Thanks / Like
    Also make sure when you find TDC for#1 that it is the firing stroke and not the exhaust stroke.

  23. #63
    Administrator David Hodgkins's Avatar
    Join Date
    Feb 2011
    Location
    Corona del Mar, CA
    Posts
    4,994
    Post Thanks / Like
    Blog Entries
    7
    I'm feeling pretty confident that if I just switch the 5 and 7 wires I'll be good to go.

    I just hope I didn't foul the plugs again.

    If that fails I'll start over beginning with TDC on #1


    FFR 5369 Pin Drive, IRS, Trigos, Torsen, Wilwoods, FMS BOSS 302 "B" cam , Mass-flo. CA SB100 (SPCN) Registered
    Delivered 4/23/06. "Finished" 4/2012 (still not done!)


  24. #64
    Senior Member frankb's Avatar
    Join Date
    Feb 2014
    Location
    Marana, AZ
    Posts
    118
    Post Thanks / Like
    David:

    The distributor on a Ford runs counterclockwise...you may need to change more than #'s 3 and 7... according to the way I see it in your photos.

    Frank B
    FFR MK4 #8317, 393 Cleveland, Lunati VooDoo solid roller, CHI 3V heads and intake, TKO 600, Std roadster seats, 8.8 3.55 diff, 17" Halibrand replica wheels, Ford "Magnetic Metallic", silver ghost stripe.

  25. #65
    Administrator David Hodgkins's Avatar
    Join Date
    Feb 2011
    Location
    Corona del Mar, CA
    Posts
    4,994
    Post Thanks / Like
    Blog Entries
    7
    Quote Originally Posted by frankb View Post
    David:

    The distributor on a Ford runs counterclockwise...you may need to change more than #'s 3 and 7... according to the way I see it in your photos.

    Frank B
    Hi Frank, thanks for chiming in.

    I used the pics showing each bank and marked the cylinders on the center shot. Here is what it looks like:



    So for me to get the right firing order (counter-clockwise starting with 1), to get to 1-3-7-2-6-5-4-8 it looks like I just need to switch 5 and 7...

    It makes sense that I was hearing the backfire from the driver's side. I'm a little surprised it ran at all!

    I was writing music last night so I didn't get to the shop. I'll drop by this afternoon and give it another shot.

    Last edited by David Hodgkins; 09-28-2018 at 11:08 AM.

    FFR 5369 Pin Drive, IRS, Trigos, Torsen, Wilwoods, FMS BOSS 302 "B" cam , Mass-flo. CA SB100 (SPCN) Registered
    Delivered 4/23/06. "Finished" 4/2012 (still not done!)


  26. #66
    Senior Member frankb's Avatar
    Join Date
    Feb 2014
    Location
    Marana, AZ
    Posts
    118
    Post Thanks / Like
    David:

    With that photo, I agree that #'s 5 and 7 are the ones that need changed. I stand corrected!

    Frank B
    FFR MK4 #8317, 393 Cleveland, Lunati VooDoo solid roller, CHI 3V heads and intake, TKO 600, Std roadster seats, 8.8 3.55 diff, 17" Halibrand replica wheels, Ford "Magnetic Metallic", silver ghost stripe.

  27. #67
    Administrator David Hodgkins's Avatar
    Join Date
    Feb 2011
    Location
    Corona del Mar, CA
    Posts
    4,994
    Post Thanks / Like
    Blog Entries
    7
    I shoulda’ took some video...

    SUCCESS!

    I didn’t drive it very far, didn’t need to. Started right up, rev’d strong, and pulls nice!

    Thanks for your help everyone!


    FFR 5369 Pin Drive, IRS, Trigos, Torsen, Wilwoods, FMS BOSS 302 "B" cam , Mass-flo. CA SB100 (SPCN) Registered
    Delivered 4/23/06. "Finished" 4/2012 (still not done!)


  28. #68
    Member Geoff H's Avatar
    Join Date
    Feb 2011
    Location
    Edmonton, Alberta
    Posts
    40
    Post Thanks / Like
    Awesome news - what a relief!

  29. #69
    Junior Member TBull's Avatar
    Join Date
    Dec 2011
    Location
    St. Louis
    Posts
    18
    Post Thanks / Like
    Great to hear. Glad it worked out for you.

  30. #70
    Jazzman's Avatar
    Join Date
    Jan 2014
    Location
    Scottsdale, AZ
    Posts
    1,071
    Post Thanks / Like
    Quote Originally Posted by David Hodgkins View Post
    I'm such an idiot.
    Oh you have no idea how good it makes many of us feel to know that even as knowledgeable as you are, you will very occasionally make mistakes like the rest of us! I am so pleased that you were finally able to figure out the problem. Now get out there and drive the wheels off of it!! Enjoy that Saturday beachside sunshine. (Wish we were there!!!)
    Jazzman

    MKIV #8745 "Flip Top" Roadster, Custom Tilt front, Coyote Engine, Tremec TKO600, Custom Interior. Best of Show winner, Huntington Beach Cruise In 2018.

    1967 Ford Mustang Coupe build thread updated 10/14/2018

    Roadster Frame Dolly Plan

  31. #71
    Administrator David Hodgkins's Avatar
    Join Date
    Feb 2011
    Location
    Corona del Mar, CA
    Posts
    4,994
    Post Thanks / Like
    Blog Entries
    7
    Quote Originally Posted by Jazzman View Post
    Oh you have no idea how good it makes many of us feel to know that even as knowledgeable as you are, you will very occasionally make mistakes like the rest of us! I am so pleased that you were finally able to figure out the problem. Now get out there and drive the wheels off of it!! Enjoy that Saturday beachside sunshine. (Wish we were there!!!)
    Quote Originally Posted by TBull View Post
    Great to hear. Glad it worked out for you.
    Quote Originally Posted by Geoff H View Post
    Awesome news - what a relief!
    Thanks Gents! Wish it was my car, I WOULD drive the wheels off it!

    Truth is it's going up for sale right after I get some pics of it next to Tommy Trojan:



    I had plans to drive it to USC football games and such... but my brother can't really drive it anymore...

    Since I finished it, it only has a little over 1K on it. It needs to be DRIVEN!

    So I'll get some glamour shots of it, for posterity.




    FFR 5369 Pin Drive, IRS, Trigos, Torsen, Wilwoods, FMS BOSS 302 "B" cam , Mass-flo. CA SB100 (SPCN) Registered
    Delivered 4/23/06. "Finished" 4/2012 (still not done!)


Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Levy Racing

Visit our community sponsor