Forte's

Visit our community sponsor

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: RT Turn Signal Problem

  1. #1
    Member
    Join Date
    Nov 2013
    Posts
    48
    Post Thanks / Like

    RT Turn Signal Problem

    Any thoughts on this Russ Thompson Turn Signal issue? Right side works flawlessly. Stalk clicks on, all lamps blink, and then the stalk returns to neutral after completing a RH turn. However, the Left side has an intermittent problem. Stalk clicks on OK, but sometimes the lamps blink, most times they don't. Stalk does return to the neutral position after completing the LH turn. TIA, Rod

  2. #2
    edwardb's Avatar
    Join Date
    Feb 2011
    Location
    Lake Orion, Michigan
    Posts
    4,845
    Post Thanks / Like
    Call or email Russ. He stands behind his stuff.
    Build 1: Mk3 Roadster #5125. Sold 11/08/2014.
    Build 2: Mk4 Roadster #7750. Sold 04/10/2017. #7750 Build Thread
    Build 3: Mk4 Roadster 20th Anniversary #8674. 03 of 20. 2015 crate Coyote, 2015 IRS. Legal 04/18/2017. #8674 Build Thread
    Build 4: Gen 3 Type 65 Coupe #59. Delivered 12/2/2017. #59 Coupe Build Thread

  3. #3
    Senior Member
    Join Date
    Mar 2011
    Location
    Heart of Dixie, Alabama
    Posts
    438
    Post Thanks / Like
    This may be caused by the pulling on the harness from the back of the steering column hub, as noted in RT's instructions.
    20th Anniversary Mk IV, A50XS Coyote, TKO 600, Trunk Drop Box, Trunk Battery Box, Cubby Hole, Seat Heaters, Radiator hanger and shroud.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Racing Adventures

Visit our community sponsor