Boig Motorsports

Visit our community sponsor

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: Fortes linkage

  1. #1
    Senior Member bil1024's Avatar
    Join Date
    Feb 2011
    Location
    NY
    Posts
    1,119
    Post Thanks / Like

    Fortes linkage

    anyone have pics of linkage installed for a Gen 3

  2. #2
    Senior Member
    Join Date
    Feb 2011
    Location
    Edmonton Alberta
    Posts
    288
    Post Thanks / Like
    I have it but no pictures that show it well. It fits fine but there is not much clearance in the foot box so it takes a little time to figure out the best location. I should have the car back here from the paint shop late today so I will try to get some pictures over the weekend.
    David W
    Mkll 4874 built in 2004
    Gen 3 coupe #16 registered 2018 painted 2019

  3. #3
    Senior Member
    Join Date
    Feb 2011
    Location
    Edmonton Alberta
    Posts
    288
    Post Thanks / Like
    Here is a picture of the engine part of the linkage. It was not hard to install. I did a quick polish with Mother's aluminum polish
    throttle.jpg
    David W
    Mkll 4874 built in 2004
    Gen 3 coupe #16 registered 2018 painted 2019

  4. #4
    Senior Member bil1024's Avatar
    Join Date
    Feb 2011
    Location
    NY
    Posts
    1,119
    Post Thanks / Like
    Quote Originally Posted by David Williamson View Post
    Here is a picture of the engine part of the linkage. It was not hard to install. I did a quick polish with Mother's aluminum polish
    throttle.jpg
    David W
    Thanks David, I see there is a mounting point at the end were is the other ? In the foot,box ? I assume you mounted it to the firewall ? Sorry for all the questions

  5. #5
    Senior Member
    Join Date
    Feb 2011
    Location
    Edmonton Alberta
    Posts
    288
    Post Thanks / Like
    Yes the other mount is in the foot box near the push rod from the pedal. I bolted the mounts to the fire wall just above the frame and used a fender washer to stiffen the aluminum. The frame was too low for the mounts. I drilled the arms and put roll pins in to keep them from turning on the rod. The throw at the engine can be adjusted by the location of the push rods on the arms. Set everything up in the foot box first, not much room and it will set the locations. Mine was the first Gen 3 Coupe with this set up and Forte did not know the exact locations so I did have to cut the tubes to length and thread the cut end with a tap.
    David W
    Mkll 4874 built in 2004
    Gen 3 coupe #16 registered 2018 painted 2019

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Racing Adventures

Visit our community sponsor